[israel-post] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The carrier has recovered and the services are back to operational.
Posted May 08, 2024 - 05:05 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "israel-post" since 2024-05-07 23:00 HKT

Our Engineers are working with the carrier to fix it on priority. We'll update you on the progress.
Posted May 07, 2024 - 22:12 EDT
This incident affected: Couriers Tracking System.