[posten-norge] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The carrier has recovered and the services are back to operational.
Posted May 09, 2024 - 05:46 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "posten-norge" since 2024-05-08 20:26 HKT

Our Engineers are working with the carrier to fix it on priority. We'll update you on the progress.
Posted May 09, 2024 - 01:54 EDT
This incident affected: Couriers Tracking System.