Delay in tracking updates for courier DHL Ecommerce US
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Feb 25, 2022 - 09:09 EST
Monitoring
We have implemented a fix and monitoring the results.
Posted Feb 25, 2022 - 05:57 EST
Investigating
We are experiencing delay while fetching tracking updates for courier DHL Ecommerce US.
Our engineers are working in order to fix it.

Affected Slug:
dhl-global-mail
Posted Feb 24, 2022 - 22:30 EST
This incident affected: Couriers Tracking System.