Maintenance of the courier SF Express
Incident Report for AfterShip Tracking
Resolved
No further updates in the follow-up of this incident.
Posted Oct 29, 2021 - 09:36 EDT
Identified
Due to unplanned maintenance at SF express, tracking updates of recently added SF express international tracking numbers is going to be delayed and updates should start flowing in from 1st Nov onwards.

Existing SF express international tracking numbers with at least one checkpoint will remain unaffected.

Reach out to our support team if you need more information on this.

Affected slugs: 'sf-express' & 'sfb2c'
Posted Oct 29, 2021 - 06:11 EDT
This incident affected: Couriers Tracking System.