Delayed tracking updates - 3 carriers
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 14:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2020 - 14:04 EDT
Investigating
Our team came across delayed updates from the following couriers. We are investigating the issue and will publish updates here as soon as possible.

dhl
dhl-nl
dhl-pieceid
Posted Apr 17, 2020 - 13:01 EDT
This incident affected: Couriers Tracking System.