UPS is down
Incident Report for AfterShip Tracking
Resolved
The courier has been recovered.
Posted Nov 11, 2021 - 02:04 EST
Investigating
This is to inform you that we have stopped receiving tracking updates from the courier UPS. Our Engineers are working in order to fix the issue.
Affected slug: ups

*All the users are affected.
Posted Nov 11, 2021 - 01:00 EST
This incident affected: Couriers Tracking System.