USPS tracking delays
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 01:31 EDT
Investigating
USPS tracking updates are delayed due to an issue at USPS side. Our team is checking with USPS and will update once the issue is resolved at their end.
Posted Jun 21, 2020 - 23:14 EDT
This incident affected: Couriers Tracking System.