Delay in DHL eCommerce tracking updates
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Nov 02, 2021 - 10:17 EDT
Monitoring
A fix has been implemented and the courier is recovering. It is still under monitoring.
Posted Oct 27, 2021 - 04:04 EDT
Identified
It is to inform that the tracking updates for the courier DHL eCommerce will be delayed. Our engineers have identified the issue and working in order to resolve it.
Posted Oct 26, 2021 - 06:11 EDT