Tracking update delay for all couriers.
Incident Report for AfterShip Tracking
Resolved
The issue has been resolved and everything is back to normal.
Posted Jul 14, 2020 - 11:15 EDT
Identified
We're facing some issues with the tracking updates. Our engineers have identified the problem and are working on the fix.
The recovery time is 30 minutes.
Posted Jul 14, 2020 - 10:37 EDT
This incident affected: Couriers Tracking System.