Branded tracking page - Search with order number not showing tracking history button
Incident Report for AfterShip
Resolved
We've fixed the issue and everything is working fine now.
Posted Apr 11, 2020 - 22:02 HKT
Update
We're still investigating the issue. Your patience is highly appreciated.
Posted Apr 11, 2020 - 21:16 HKT
Identified
Our engineers have identified the issue and are working to resolve this ASAP.

P.S. The branded tracking page is working fine with the tracking number. The impact is limited to search by the combination of email ID and order ID
Posted Apr 11, 2020 - 20:39 HKT
This incident affected: Secure Web Portal.