DPD - Delayed Tracking Updates
Incident Report for AfterShip
Resolved
The incident at the carrier's end has been resolved and the system is back to normal.
Posted Feb 08, 2021 - 07:56 EST
Identified
Due to an ongoing issue at the carrier side, there might be some delay in getting delivery updates. We will keep an eye out and update here once resolved.
slug: dpd
Posted Feb 08, 2021 - 07:17 EST
This incident affected: Couriers Tracking System.