Tracking Destination Address Issue
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is working as expected. We appreciate your patience with us.
Posted Sep 02, 2024 - 03:34 EDT
Investigating
We have identified an issue where the destination address information for some tracking numbers are not pulling the complete destination address.

Our team is actively working to resolve this issue and ensure that all address information is fully visible. We will keep you update on the progress.
Posted Sep 01, 2024 - 23:47 EDT
This incident affected: Couriers Tracking System.