Degraded performance on AfterShip and Returns Center
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 15:22 EDT
Monitoring
A fix has been implemented at Google's end and we are monitoring the results.
Posted Mar 17, 2021 - 15:17 EDT
Investigating
We have observed degraded performance in AfterShip and Returns center. On further investigation, we found that this happened due to networking issues at Google Cloud. Please visit https://status.cloud.google.com/incident/cloud-networking/21006#21006002 for more information.
Posted Mar 17, 2021 - 14:13 EDT
This incident affected: API, Public Web Portal, Secure Web Portal, and Couriers Tracking System.