Yun Express - Delayed Tracking Updates
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Apr 01, 2021 - 10:48 EDT
Investigating
The carrier Yun Express has some problems due to an ongoing issue. Our engineers have identified the issue and working with the courier in order to resolve it.

There might be some delay in getting tracking updates.
Posted Apr 01, 2021 - 06:57 EDT
This incident affected: Couriers Tracking System.