UPS - Delayed Tracking Updates
Incident Report for AfterShip Tracking
Resolved
The issue has been resolved and all services are back to normal for UPS
Posted Jun 03, 2021 - 01:40 EDT
Investigating
Due to an ongoing issue, there might be some delay in getting delivery updates. We will keep an eye out and update here once resolved.
Posted Jun 02, 2021 - 23:45 EDT
This incident affected: Couriers Tracking System.