Delayed tracking updates - 7 carriers
Incident Report for AfterShip Tracking
Resolved
This issue has been resolved. We will continue to monitor for a few hours.
Posted Feb 14, 2020 - 11:41 EST
Update
We are continuing to work on a fix for this issue. Here is the latest status.

fedex (recovering)
gls-italy (recovering)
singapore-post (recovering)
russian-post (recovering)
aramex (recovering)
china-post (recovering)
dhl-global-forwarding (recovering)
Posted Feb 14, 2020 - 08:50 EST
Update
We are continuing to work on a fix for this issue.
Posted Feb 14, 2020 - 08:30 EST
Update
We are continuing to work on a fix for this issue. Here is the latest status.

fedex (recovering)
gls-italy (recovering)
singapore-post (recovering)
russian-post (recovering)
aramex (recovering)
china-post
dhl-global-forwarding
Posted Feb 14, 2020 - 07:07 EST
Identified
The issue has been identified and we are working on a fix. Here is the latest status.

fedex (recovering)
china-post
gls-italy (recovering)
singapore-post (recovering)
russian-post (recovering)
aramex (recovering)
dhl-global-forwarding
Posted Feb 14, 2020 - 05:56 EST
Investigating
Our team came across delayed updates from the following couriers. We are investigating the issue and will publish updates here as soon as possible.

fedex
china-post
gls-italy
singapore-post
russian-post
aramex
dhl-global-forwarding
Posted Feb 14, 2020 - 05:18 EST
This incident affected: Couriers Tracking System.