FedEx and USPS - Delayed Tracking Updates
Incident Report for AfterShip
Resolved
The incident at FedEx's end has been resolved and the system is back to normal.
Posted Feb 22, 2021 - 00:56 EST
Update
USPS has recovered but FedEx is still experiencing some timeout-related issues.
Posted Feb 21, 2021 - 23:48 EST
Update
FedEx (slug: fedex) has some problems due to an ongoing issue at the carrier side, there might be some delay in getting delivery updates.
USPS (slug: usps) system is down and we are not able to receive any tracking data for now.

We will keep an eye out and update here once resolved.
Posted Feb 21, 2021 - 22:58 EST
Identified
Courier FedEx (slug: fedex) has some problems due to an ongoing issue at the carrier side, there might be some delay in getting delivery updates. We will keep an eye out and update here once resolved.
Posted Feb 21, 2021 - 22:42 EST
This incident affected: Couriers Tracking System.