AfterShip AWS CN Service is Impacted
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is working as expected. We appreciate your patience with us
Posted Sep 03, 2024 - 06:13 EDT
Investigating
AfterShip AWS CN service is impacted and we are not able to fetch tracking updates from the China-Post carrier, we are actively investigating the issue.
Posted Sep 03, 2024 - 05:13 EDT
This incident affected: Couriers Tracking System.