La Poste & Colissimo - Delayed Delivery Updates
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Jan 28, 2021 - 04:31 EST
Identified
Due to an ongoing issue at the carrier side, there might be some delay in getting delivery updates. We will keep an eye out and update here once resolved.
slug: la-poste-colissimo and colissimo
Posted Jan 28, 2021 - 01:06 EST
This incident affected: Couriers Tracking System.