DHL eCommerce US (dhl-global-mail) tracking data discrepancy
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Dec 11, 2019 - 01:54 EST
Investigating
Our team have identified and fixed an issue related to DHL eCommerce US (dhl-global-mail) tracking data. A fix has been applied and data is corrected. Our team is working on to find ways to avoid such issues in future.
Affected date range is 3rd Dec 2019 to 11th Dec 2019
Posted Dec 11, 2019 - 01:54 EST
This incident affected: Couriers Tracking System.