Brazil Correios is dead
Incident Report for AfterShip Tracking
Resolved
The courier has been recovered.
Posted Oct 28, 2021 - 06:41 EDT
Investigating
It is reported that courier Brazil Correios is dead. Tracking updates will be delayed. Our engineers are working in order to fix the issue.
Posted Oct 27, 2021 - 04:11 EDT
This incident affected: Couriers Tracking System.