Verify email link is not working for new users
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Jun 30, 2020 - 07:19 EDT
Identified
We have identified the issue and working on a fix.
Posted Jun 30, 2020 - 06:28 EDT
Investigating
Our engineering team has identified an issue preventing users from verifying the email after registering new accounts. stay tuned for updates.
Posted Jun 30, 2020 - 04:59 EDT
This incident affected: Secure Web Portal.