[professional-couriers] is currently partially unavailable
Incident Report for AfterShip
Resolved
The incident has been resolved and the service is fully operational.
Posted Oct 15, 2024 - 03:06 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "professional-couriers" since 2024-10-14 20:00 HKT.

Our team is working on priority to fix it. We'll update you on the progress.
Posted Oct 14, 2024 - 22:28 EDT
This incident affected: Couriers Tracking System.