Slowness and Error - Branded Tracking page & Branded Returns page
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Jun 20, 2021 - 06:47 EDT
Update
Our team believes this may be network related issue and is working on to confirm and fix.
Posted Jun 20, 2021 - 03:35 EDT
Investigating
1% visitors may face slowness or receive error while accessing following
1. Branded Tracking page
2. Branded Returns page
3. Returns Center admin
4. All Automizely products
Posted Jun 20, 2021 - 03:25 EDT
This incident affected: Public Web Portal.