Users are facing issues while subscribing new plans
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted May 11, 2020 - 13:55 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2020 - 13:17 EDT
Investigating
AfterShip and Returns Center users are facing issues while performing the following operations.
1. Add/Update payment method.
2. Subscribe to a new plan.
Existing users are not impacted. We are working with our payment processor to resolve this issue on priority.
Posted May 11, 2020 - 13:16 EDT
This incident affected: Secure Web Portal.