AfterShip secure web portal login service not working
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Jul 28, 2020 - 23:41 HKT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2020 - 22:53 HKT
Investigating
We are currently investigating this issue. The following services are impacted.
1. Secure AfterShip login
2. Secure Returns Center login
3. Secure Postmen login
4. Secure Automizely login
Posted Jul 28, 2020 - 22:45 HKT
This incident affected: Secure Web Portal.