Delay in DHL tracking updates
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 11:05 EST
Monitoring
the issue with DHL Tracking updates has been fixed now. and we are monitoring this.
Posted Feb 07, 2022 - 09:02 EST
Identified
It is observed that the tracking updates of the courier DHL are being delayed. Our engineers have already identified the issue and working on a fix.

Affected Slugs:
dhl
dhl-pieceid
dhl-reference
Posted Feb 07, 2022 - 05:36 EST
This incident affected: Couriers Tracking System.