Carrier parcel-force is unstable - Start Time - 2026/05/20 02:39 UTC - End Time - 2026/05/20 03:19 UTC

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted May 19, 2026 - 23:19 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2026 - 23:05 EDT

Investigating

Carrier parcel-force is currently unstable.
Posted May 19, 2026 - 22:39 EDT
This incident affected: Couriers Tracking System.