High Latency for Public APIs [Stating time: 2025/06/12 19:00 UTC - Resolve time: 2025/06/12 22:00 UTC]

Incident Report for AfterShip

Resolved

All of our products have returned to normal. We are still monitoring any edge scenarios and resolve as observed.
Resolve time: 2025/06/12 22:00 UTC
Posted Jun 12, 2025 - 18:07 EDT

Update

All products are back to normal now and are operational apart from Returns and Feed. We are working on restoring Returns and Feed services as well.
Posted Jun 12, 2025 - 17:22 EDT

Update

We are continuing to investigate this issue.
Posted Jun 12, 2025 - 15:57 EDT

Investigating

Because the influence of the incident of the GCP cloud vendor, the latency of many of our Public APIs has increased.
Posted Jun 12, 2025 - 15:56 EDT
This incident affected: Public API (Tracking, Returns, Shipping, Protection, Commerce, Warranty, Personalization) and Admin Portal (Feed).