[osm-worldwide] is partially unavailable
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the carrier is back to normal. We appreciate your patience with us.
Posted Jun 28, 2024 - 10:34 EDT
Investigating
We have been facing issues while getting the tracking updates for the carrier "osm-worldwide" since 2024-06-28 13:00 HKT

We are working with the carrier to fix it on priority. We'll update you on the progress.
Posted Jun 28, 2024 - 06:33 EDT
This incident affected: Couriers Tracking System.