Intermittent Issue on UPS tracking
Incident Report for AfterShip Tracking
Resolved
Thank you for your patience. The incident has been resolved.
Posted Mar 13, 2023 - 07:51 EDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2023 - 06:43 EDT
Investigating
UPS is experiencing some technical problems and we are not getting tracking updates.

Affected slugs:
ups
ups-mi
ups-freight
ups-reference
Posted Mar 13, 2023 - 06:19 EDT
This incident affected: API, Public Web Portal, Secure Web Portal, and Couriers Tracking System.