[dpd] is currently partially unavailable

Incident Report for AfterShip

Resolved

The incident has been resolved and the service is fully operational.
Posted Oct 15, 2024 - 05:46 EDT

Update

Our team is dedicatedly working on this concern to get it fixed as soon as possible. We'll keep you posted on the progress
Posted Oct 15, 2024 - 03:11 EDT

Investigating

We have been facing issues while getting the tracking updates for the carrier "dpd" since 2024-10-14 20:00 HKT.

Our team is working on it. We'll update you on the progress.
Posted Oct 14, 2024 - 22:26 EDT
This incident affected: Couriers Tracking System.