Incorrect Contact Counts in Filters & Segments – AfterShip Email SMS Marketing, Popups & Forms

Incident Report for AfterShip

Resolved

The issue is now fixed.
Posted Aug 15, 2025 - 12:51 EDT

Update

The data is being restored.
Posted Aug 14, 2025 - 02:19 EDT

Identified

We have identified an issue causing contact filters and segments to display incorrect contact counts. We are working on a resolution.
Posted Aug 13, 2025 - 05:31 EDT
This incident affected: Admin Portal (Email, SMS, Popups & Forms).