Resolved
This incident has been resolved.
Posted Aug 06, 2025 - 00:36 EDT
Identified
The issue has been resolved, and services have recovered. We are currently processing a backlog of data on our end to ensure complete restoration and system stability.
Posted Aug 06, 2025 - 00:29 EDT
Update
Our team is working on it, and it is currently being recovered; however, we are still validating full restoration of all business services. will update the progress
Posted Aug 06, 2025 - 00:11 EDT
Update
We are continuing to investigate this issue.
Posted Aug 05, 2025 - 23:40 EDT
Investigating
We are currently experiencing network anomalies in Google Cloud Platform (GCP) since 2025/08/06 2:43 AM UTC, which are resulting in widespread service disruptions. Our team is actively investigating the issue. We have contacted GCP Technical Support for assistance with resolving the issue internally and have filed a GCP ticket at the highest level
Posted Aug 05, 2025 - 23:25 EDT
This incident affected: Public API (Tracking, Returns, Shipping, Protection, Parser, Commerce, Members, Address, Warranty, Personalization), Admin Portal (Tracking, Returns, Personalization, Feed, EDD, Shipping, Protection, Green, Email, SMS, Popups & Forms, Reviews, Page Builder, Affiliate), and Couriers Tracking System, Couriers Shipping System, Third party services.