Delay in Tracking Updates
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the services are fully operational.
Posted Apr 23, 2024 - 01:44 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 23, 2024 - 00:49 EDT
Update
We have identified the root cause and it has started to recover (may take an hour).

We'll update you on the further progress.
Posted Apr 23, 2024 - 00:49 EDT
Investigating
There is a problem with our carrier system, which affects all carriers and expecting a delay in tracking updates.

We are working to fix it on priority. We'll update you on the progress.
Posted Apr 23, 2024 - 00:40 EDT
This incident affected: Couriers Tracking System.