[ups-mi] & [ups-freight] No Tracking Updates
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved and getting the tracking updates
Posted May 25, 2023 - 04:55 EDT
Update
We are still working on it and we will keep you informed for the further update
Posted May 23, 2023 - 23:45 EDT
Investigating
We are facing issues while getting the tracking updates from the carrier [ups-mi] & [ups-freight]. Our team is working on getting this fixed on priority.
Posted May 23, 2023 - 11:05 EDT
This incident affected: Couriers Tracking System.