Chat Support Outage (Tool - Crisp) | Start Time: 2026/05/04 08:00 UTC- End Time: 2026/05/04 08:25 UTC.

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted May 04, 2026 - 04:26 EDT

Investigating

Our chat support provider (Crisp) is currently facing issues with their services.
For any urgent queries, please reach out to us at support@aftership.com
Posted May 04, 2026 - 04:10 EDT