Royal mail is currently unavailable

Incident Report for AfterShip

Resolved

The incident has been resolved.
All services are back to normal and operational.
Posted Feb 16, 2025 - 22:17 EST

Investigating

We have been facing issues while getting the updates for the carrier "royal-mail".

Our team is working on priority to fix it. We'll update you on the progress.
Posted Feb 16, 2025 - 08:35 EST
This incident affected: Couriers Tracking System.