Tracking Updates From [korea-post] Are Currently Unavailable - Start time: 2025-09-26 11:30:00 UTC

Incident Report for AfterShip

Resolved

The carrier is recovering and we are getting tracking updates now.
Posted Sep 29, 2025 - 06:18 EDT

Investigating

We are currently experiencing issues with the carrier "Korea-Post" [slug: kpost]. We have contacted the carrier to resolve the issue.
Posted Sep 28, 2025 - 03:21 EDT
This incident affected: Couriers Tracking System.