Issue with Amazon tracking updates
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is fully operational. We appreciate your patience with us.
Posted May 30, 2024 - 06:10 EDT
Investigating
We are currently experiencing issues while getting updates for a few Amazon tracking numbers.
Affected slugs: amazon, swiship, amazon-uk-api, amazon-fba-swiship, amazon-fba-swiship-de

Our team is working on the fix and we will keep you updated further.
Posted May 06, 2024 - 06:02 EDT
This incident affected: Couriers Tracking System.