Courier: Hermes UK API Down
Incident Report for AfterShip
Resolved
This incident has been resolved
Posted Sep 04, 2022 - 11:32 EDT
Identified
Our team is working on fixing it. We will update here once the issue is resolved.
Posted Sep 04, 2022 - 10:14 EDT
This incident affected: Couriers Tracking System.