Chat Support Outage (Tool - Crisp) | Start Time: 2026/03/02 14:00 UTC - End Time: 2026/03/02 14:43 UTC.

Incident Report for AfterShip

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 09:46 EST

Investigating

Our chat support provider (Crisp) is currently facing issues with their services.
For any urgent queries, please reach out to us at support@aftership.com
Posted Mar 02, 2026 - 09:31 EST