Purolator is unstable - Start Time: 2025/11/05 15:00 UTC - End Time: 2025/11/05 19:25 UTC

Incident Report for AfterShip

Resolved

The carrier has recovered.
Posted Nov 05, 2025 - 14:27 EST

Update

The carrier Puralator is currently unstable.
Posted Nov 05, 2025 - 13:45 EST

Identified

The carrier Puralator is currently unstable.
Posted Nov 05, 2025 - 13:40 EST
This incident affected: Couriers Shipping System.