Tracking update delay for all couriers.
Incident Report for AfterShip Tracking
Resolved
The issue has been resolved.
Posted Apr 29, 2020 - 09:32 EDT
Identified
We're experiencing a delay in tracking updates due to some issues with Cloudflare. Our engineers have identified the issue and are working to resolve this ASAP
Posted Apr 29, 2020 - 08:53 EDT
This incident affected: Couriers Tracking System.