USPS - Active Shipments getting incorrectly marked as "Delivered"

Incident Report for AfterShip

Resolved

We have resolved the underlying issue, and all new shipments will now display the correct status. Our team is working on updating the status of shipments that were previously incorrectly marked as “Delivered.”
Posted Jun 24, 2025 - 15:54 EDT

Investigating

We’re investigating an issue where some USPS packages are incorrectly showing a “Delivered” status. Our team is working with the carrier to resolve this as quickly as possible. We appreciate your understanding and patience.
Posted Jun 24, 2025 - 15:05 EDT
This incident affected: Couriers Tracking System.