Delay in tracking updates for courier DHL Ecommerce US
Incident Report for AfterShip Tracking
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 05:56 EST
Update
We are continuing to investigate this issue at our end and our Engineers are working on it. We will implement a fix soon.
Posted Feb 27, 2022 - 22:18 EST
Investigating
We are experiencing delay while fetching tracking updates for courier DHL Ecommerce US.
Our engineers are working in order to fix it.

Affected Slug:
dhl-global-mail
Posted Feb 26, 2022 - 03:33 EST
This incident affected: Couriers Tracking System.