[usps] is currently unavailable
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Oct 17, 2023 - 06:42 EDT
Update
The services are back to operational from 2023-10-17 17:42 (UTC+8).

We appreciate your patience with us.
Posted Oct 17, 2023 - 06:41 EDT
Investigating
We are facing issues while getting the tracking updates from the carrier "usps" from 2023-10-17 13:08 (UTC+8)

Our team is working on getting this fixed on priority.
Posted Oct 17, 2023 - 04:16 EDT
This incident affected: Couriers Tracking System.