[skynetworldwide] is currently unavailable

Incident Report for AfterShip

Resolved

The incident has been resolved and the carrier is back to normal. We appreciate your patience with us.
Posted Jul 16, 2024 - 21:50 EDT

Update

We are still working on this issue and will keep you updated on the progress.
Posted Jul 15, 2024 - 02:01 EDT

Update

We are continuously investigating this issue and will keep you updated on the progress.
Posted Jul 12, 2024 - 07:13 EDT

Update

We are continuously investigating this issue and will keep you updated on the progress.
Posted Jul 12, 2024 - 00:37 EDT

Investigating

We have been facing issues while getting the tracking updates for the carrier "skynetworldwide" since 2024-07-09 16:30 HKT.

We are working to fix it on priority. We'll update you on the progress.
Posted Jul 11, 2024 - 06:42 EDT
This incident affected: Couriers Tracking System.