Yanwen - Tracking updates delay
Incident Report for AfterShip Tracking
Resolved
This issue has been resolved.
Posted Mar 03, 2020 - 19:55 EST
Identified
Yanwen is facing a technical issue at their end resulting into tracking delays at AfterShip. The ETA to fix this problem at Yanwen side is tomorrow morning. We will post updates as soon as we hear back from the team Yanwen.
Posted Mar 03, 2020 - 11:03 EST
This incident affected: Couriers Tracking System.