UkrPoshta Is down
Incident Report for AfterShip
Resolved
This incident has been resolved.
Posted Mar 09, 2022 - 00:49 EST
Investigating
This is to inform you that we have stopped receiving tracking updates from the courier UkrPoshta. Our Engineers are working in order to fix the issue.

Affected slug: ukrposhta

*All the users are affected.
Posted Mar 08, 2022 - 07:34 EST